The Makers of FDR®

September 6, 2007

INNOVATION DATA PROCESSING ANNOUNCEMENTS

IMPORTANT TECHNICAL BULLETIN FOR COMPAKTOR USERS

If you are running z/OS 1.8 or higher and you are using new PDSE features PDSE_BUFFER_BEYOND_CLOSE(YES) and/or PDSE1_BUFFER_BEYOND_CLOSE(YES), you will need to apply the following ZAP as soon as possible. COMPAKTOR V5.4 L61 shipments on September 6th, 2007 and later will automatically have this zap P-54.5600 included. If you are running a version of COMPAKTOR lower than V5.4 L55, you will need to upgrade.

*****    ZAP-ID#   : P-54.5600
*        DATE      : 07.247
*        SYMPTOMS  : ABEND S0F4, SVC DUMP WITH
*                    TITLE=COMPID=DF115,CSECT=IGWBIEX1+0B0E.  AFTER
*                    MOVING PDSE FILE ON Z/OS 1.8 WITH BUFFER BEYOND
*                    CLOSE FEATURE ENABLED.
*        PROBLEM   : Z/OS 1.8 HAS THE NEW OPTIONS
*                    PDSE_BUFFER_BEYOND_CLOSE(YES) AND
*                    PDSE1_BUFFER_BEYOND_CLOSE(YES) TO KEEP PDSE
*                    DIRECTORY AND MEMBER DATA IN MEMORY AFTER A PDSE
*                    IS CLOSED.  IF CPK MOVES THESE DATA SETS, SYSTEM
*                    ABENDS AND OTHER ERRORS OCCUR.
*        SOLUTION  : ISSUE IGWNOTIF TO CLEAR IN-CORE BUFFERS.
*        MODULE(S) : FDRRESTR
*-
   NAME  FDRRESTR  FDRRESTR
   IDRDATA P545600
   VER  07AE  9180,D64B,4780,C7FA,9102,905A,4780,C7FA
   VER  07BE  9108,9056,4780,C7FA
   VER  1CD0  BCD0,BCD2
   REP  07AE  9102,905A,4780,C7FA,9108,9056,4780,C7FA
   REP  07BE  47F0,BCD0,0101,0100
   REP  1CD0  9142,D647,4780,C7C6,9102,9056,4710,C7C6
   REP  1CE0  58E0,0010,58E0,E4C0,D503,E010,C7C2,4740
   REP  1CF0  C7C6,58E0,E02C,BFEF,E0B4,4780,C7C6,4110
   REP  1D00  003C,0A6B,4110,D958,D70B,1000,1000,9202
   REP  1D10  1001,D205,1002,D1F0,1FFF,BFF3,9000,4CF0
   REP  1D20  D40C,4AF0,9002,40F0,1008,D200,100A,9004
   REP  1D30  18FE,0CEF,4110,0024,0A6B,47F0,C7C6
   CHECKSUM  FB66DC02
*
*****    END OF MODIFICATION
	  
NOTE:

You can display the current PDSE options with the operator command D SMS,OPTIONS. If your options are set as follows, you do not have any exposure to this problem but we recommend that you still apply the zap.

 
PDSE_BUFFER_BEYOND_CLOSE = NO
PDSE1_BUFFER_BEYOND_CLOSE = NO

If either of these options is set to YES, and you run FASTCPK on volumes containing PDSEs, then you must upgrade COMPAKTOR or apply ZAP P-54.5600 before the next FASTCPK run. If there will be a delay, then you can change the options by specifying:

 
PDSE_BUFFER_BEYOND_CLOSE(NO)
PDSE1_BUFFER_BEYOND_CLOSE(NO)

in PARMLIB member IGDSMSxx, and re-IPLing.

This fix can be downloaded from the Innovation FTP site at

http://www.innovationdp.fdr.com/ftp/ftp.cfm

from file
/download/FDR_V54/P545600.txt

If you have not already registered for FTP access, click on the "Register for FTP Site Access" link. If you are already registered, enter your access code (use capitals for any letters in your access code) and click on the "FTP Login" link.

To upgrade, please click on this link: http://www.innovationdp.fdr.com/upgrade/exform.cfm