The Makers of FDR®

August 1, 2006

INNOVATION DATA PROCESSING ANNOUNCEMENTS FOR IAM

Support for z/OS 1.8

IAM is ready for z/OS 1.8. IAM V8.0/33 or higher, or IAM V8.1/04 or higher is the minimum level required to run under z/OS 1.8. If use of the Large Format Sequential datasets for IAM is desired then IAM V8.1/04 or higher is required.

IAM V8.1 Buffer Defaults

IAM Version 8.1 changed some of the default values for the Global Options. In particular, the values for BUFSP and CICSBUFSP which affect the maximum number of buffers IAM will use for a file have been substantially increased. Additionally, the values specified for these parameters in Version 8.1 were revised to be Kilobytes, meaning that IAM will multiply the supplied value by 1024.

Some users have run into storage problems with the new values. Also, other users who changed the values to match what they had set in their prior release did not divide their old values by 1024, which has caused virtual storage problems. These problems could be seen as either IAMW08 messages, or various out of storage abends such as S878 or S80A.

Below is JCL to change the IAM V8.1 Global buffer options to be the same as the defaults in prior releases:

//*
//* SET BUFFER DEFAULTS TO MATCH PRIOR RELEASES
//*
//SETBUFSP EXEC PGM=IAMZAPOP
//STEPLIB DD DSN=IAM.LIBRARY,DISP=SHR
//SYSPRINT DD SYSOUT=A
//SYSLIB DD DSN=IAM.LIBRARY,DISP=SHR
//SYSIN DD *
ZAP BUFSP=875,CICSBUFSP=256
PRINT
/*